Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Virtuino IOT and ESP-01
What's the reason that ESP-01 cannot work as websocket , it is a hardware problem or something else.
Virtuino iot gettingstarted example works fine with my nodemcu and wemos but with ESP-01 i can upload but can't connect to my network.
I don't know because I don't use this module, but I think it is better to make this question to the ESP forum.
Can you find an example with socket connection that works as server with esp-01?
Then it is easy to modify the code.
I ran Virtuino on ESP-01 without any problem. I recommend ESP-01S with 1MB RAM
Finally i made connection to my home network and works perfect , without use manually  IPAddress ip(192,168,1,150) and w/o gateway. I will attempt to find a way to connect with manual ip and i will post again.
try entering both DNS addresses

for me it looks like this

IPAddress ip(192, 168, 2, 174);           
IPAddress gateway(192, 168, 2, 1);
IPAddress subnet(255, 255, 255, 0);       
IPAddress ip4 = ipaddr_addr( "" );  //dns 1
IPAddress ip5 = ipaddr_addr( "" );  //dns
The problem solved.
I add two lines IPAddress subnet(255, 255, 255, 0);  and  WiFi.config(ip, gateway, subnet); before line WiFi.begin(ssid, password);

Forum Jump:

Users browsing this thread: 2 Guest(s)