Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server Problems
#11
(03-01-2023, 05:51 AM)woodnboats Wrote: My NodeMCU server quit working properly about two days ago. Looking at the output on the serial monitor, saw that the sketch was running properly, but about every two or three loops it would return :

1234!V00=?$!V03=?$!V02=?$!V01=?$

invalid request

and then continue looping properly for several iterations. I reloaded the sketch, but got the same results. I then tried a different NodeMCU, and it worked perfectly, so I surmise that the problem is with the NodeMCU.

Now, however, I am unable to connect my project to the new NodeMCU. I changed the server IP to the new one, but I get an orange bar with no text when I test connectivity, which I had once before, and apparently it had to do with the Virtuino library, or the NodeMCU libray. Ilias helped me fix that, but the server settings page doesn't give me the options to change them. I decided to ignore the orange bar and see what would happen. Enabled the server, put the device back into the system, and it connects right up! But it is not displaying data on the dashboard. It is supposed to read four DS18B20 probes, but the display reads zero for all four. When I read the serial monitor on the bench with no probes, I got -196 for each probe, and in the past, when the probes were disconnected I got -196 on the Virtuino dashboard as well. The zeros make me think that there is still a library problem, but I can't change them in server settings, nor can I figure out how to remove this server and create a new one with the proper libraries.

Any help would be much appreciated.

If I could figure out how, I'd attach the sketch and project files.

---------------------------------------------------------------------------------------------------------------------------
It sounds like you're experiencing some frustrating issues with your NodeMCU server. Since you've already tried reloading the sketch and using a different NodeMCU without success, it's likely there's a problem with the NodeMCU itself. As for connecting your project to the new NodeMCU, it seems like there may be some issues with the server settings and libraries. Have you tried checking the compatibility of the Virtuino library with your new NodeMCU? Additionally, you might want to explore the differences between shared hosting vs dedicated hosting to see if switching to a dedicated hosting solution could potentially resolve your issues.
Reply
#12
The problem you're describing with your NodeMCU server seems to have two parts right?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)